Skip to content

Instalar VLC en openSUSE

21/febrero/2008

VLC media player (inicialmente VideoLAN Client) es un reproductor multimedia del proyecto VideoLAN; es un software libre distribuido bajo la licencia GPL. Soporta muchos códecs de audio y video, así como diferentes tipos de archivos, además soporta los formatos de DVD, VCD y varios protocolos streaming.

También puede ser utilizado como servidor en unicast o multicast, en IPv4 o IPv6 , en una red de banda ancha. Utiliza la biblioteca códec libavcodec del proyecto FFmpeg para manejar los muchos formatos que soporta, y emplea la biblioteca de descifrado DVD libdvdcss para poder reproducir los DVDs cifrados. Además VLC tiene soporte para Video4Linux.

Es uno de los reproductores más independientes, en cuanto a plataforma se refiere, con versiones para Linux, Microsoft Windows, Mac OS X, BeOS, BSD, Pocket PC, Solaris.

En Windows, Linux, y algunas otras plataformas, VLC incluye un plug-in Mozilla, que permite ver algunos archivos Quicktime y Windows Media en las webs sin tener que utilizar un reproductor de Microsoft o Apple.

De la versión 0.8.2 en adelante, VLC viene con un plugin ActiveX, que permite ver algunos archivos QuickTime y Windows Media en las propias webs, cuando se navega con Internet Explorer.

Existe una versión portátil de VLC media player que puede ser transportada y usada directamente desde una memoria USB sin necesidad de instalarse en el computador.

Por todo lo anterior, es recomendable instalar este excelente programa en nuestro querido openSUSE. Y nada más fácil que hacerlo a través de 1-click install (Ver enlaces más adelante).

Cuando finalice la instalación, ya podremos disfrutar de cualquier archivo multimedia, ya sea de audio, video, DVD, CDs, etc.

Enlaces:

15 comentarios
  1. 21/mayo/2008 8:50 pm

    Gracias por el post, no me ha servido exactamente ya que estoy usando la beta de Open Suse, y no funciona, pero con solo añadir las fuentes que has pasado ya funciona y ya lo tengo listo, gracias.

    Un saludo desde Dublin

  2. 21/mayo/2008 10:45 pm

    Desde Dublin???
    Que bueno que te haya servido en algo.

    Si usas openSUSE 11.0, tal vez te podría servir este enlace:
    http://download.videolan.org/pub/vlc/SuSE/11.0/i586/vlc-0.8.6f-12.10.i586.rpm

    Saludos

  3. yessica permalink
    26/julio/2010 9:25 pm

    disculpa pero tengo suse 11.2 y no me acepta los repositorios ni desde la pagina principal de suse ni tampoco instalando desde videoland, me dice que no funcional la base de metadatos

  4. Nena permalink
    22/octubre/2010 7:40 pm

    Hola, gracias por el link, pero me tira un error de que no tiene de donde obtener la librería livdvdread.so.3 para poder instalarlo, si sabes como se arregla te lo agradeceré.

    Saludos

    PD:adjunto SS.
    http://img220.imageshack.us/f/errorvlc.png/

  5. Nena permalink
    24/octubre/2010 9:06 am

    Hola Alex, ya intenté con todos los archivos de esa página, pero todos tiran el mismo error: El archivo o enlace de instalación que ha abierto no contiene instrucciones para esta versión de openSUSE.

    El archivo de instalación que sale en el segundo comentario es el que trata de instalar y da el error de la librería antes mencionada. Si sabes como esto se arregla lo agradeceré.

    Saludos

    • alexsandovalm permalink*
      24/octubre/2010 11:22 am

      Hola Nena: Podrías indicar que versión de openSUSE estás utilizando (en la consola escribe: “uname -a” (sin las comillas) y luego pega aquí lo que te salga)
      Saludos.

      • Nena permalink
        10/noviembre/2010 8:27 pm

        La versión en la que se presenta el error es la openSUSE 11.

        No me había fijado que respondes en el mismo día que pregunto, revisaré más seguido las respuestas.

        Saludos

      • Nena permalink
        11/noviembre/2010 8:28 pm

        Hola Alex,

        Lo que entrega la consola es

        uname -a
        Linux linux-532x 2.6.32.5-0.1.1.1026.1.PTF-pae #1 SMP 2010-01-25 17:19:14 +0100 i686 i686 i386 GNU/Linux

        Saludos

      • alexsandovalm permalink*
        15/noviembre/2010 9:34 pm

        Estimada Nena, no había tenido tiempo de responderte, pero quisiera pedirte otro dato, si pudieras indicarme que es lo que te muestra el siguiente comando: cat /etc/SuSE-release

        Saludos.

  6. Nena permalink
    17/noviembre/2010 9:12 pm

    Estimado Alex,

    Te indico lo que muestra el comando:
    cat/etc/SuSE-release

    SUSE Linux Enterprise Desktop 11(i586) VERSION=11 Patchlevel=0

    Espero tu respuesta,

    Saludos

    • alexsandovalm permalink*
      17/noviembre/2010 10:48 pm

      Estimada Nena, por lo que me indicas (la versión de SUSE que estas utilizando, y no openSUSE) favor intentar lo siguiente como root en la consola:

      $ zypper ar http://download.videolan.org/pub/vlc/SuSE/11.0/i586/ VLC
      $ zypper mr -r VLC
      $ zypper -v in vlc

      prueba ingresando de a 1 comando a la vez y luego nos comentas si te resulto.

      Si el sistema te indica que no logra encontrar libdvdread en los repositorios, prueba con el siguiente enlace:

      http://software.opensuse.org/ymp/multimedia:libs/SLE_11/libdvdread4.ymp?base=SUSE%3ASLE-11&query=libdvdread

      Saludos.

      • Nena permalink
        20/noviembre/2010 9:51 pm

        Estimado Alex,

        A continuación te escribo lo que entregó cada comando:

        sudo zypper ar http://download.videolan.org/pub/vlc/SuSE/11.0/i586/ VLC
        Añadiendo el repositorio VLC [TERMINADO]
        El repositorio VLC se ha añadido correctamente
        Activado: Sí
        Actualización automática: No
        URI: http://download.videolan.org/pub/vlc/SuSE/11.0/i586/

        sudo zypper mr -r VLC
        La actualización automática se ha habilitado para el repositorio VLC.

        zypper -v in vlc
        Nivel de detalle: 1
        Argumentos de programa que no son opciones:’vlc’
        Iniciando destino
        Comprobando si es necesario actualizar los metadatos para KDE:Qt
        Comprobando si es necesario actualizar los metadatos para KDE:Unstable:Playground
        Comprobando si es necesario actualizar los metadatos para KDE:Unstable:SC
        Comprobando si es necesario actualizar los metadatos para VLC
        Recuperando los metadatos del repositorio VLC. [error]
        El repositorio VLC no es válido.
        Historial:
        – [|] Repository type can’t be determined.
        – [|] No se han encontrado metadatos válidos en las URL especificadas.
        Compruebe si los URI definidos para este repositorio apuntan a un repositorio válido.
        Advertencia:Inhabilitando el repositorio VLC debido al error anterior.
        Comprobando si es necesario actualizar los metadatos para devel:tools:building
        Comprobando si es necesario actualizar los metadatos para openSUSE:11.2
        Comprobando si es necesario actualizar los metadatos para vlc
        Cargando datos del repositorio…
        Leyendo los paquetes instalados…
        Forzar resolución: Sí
        Resolviendo dependencias de paquete…
        Forzar resolución: Sí

        Problema: no hay nada que proporcione libdvdread.so.3, necesario para vlc-noX-1.1.2-2.8.i586
        Solución 1: no preguntar si se debe instalar una solución que proporciona vlc

        Elija la solución anterior usando 1 o cancele usando c [1/C]:1
        Se está aplicando la solución 1
        Resolviendo dependencias…
        Resolviendo dependencias de paquete…
        Forzar resolución: Sí
        No hay nada que hacer.

        Luego descargué el archivo que se indica por no encontrar la librería y procedí a instalarlo, sin problemas.

        Luego reescribí el último comando, pero entrega el mismo error.

        Escribí todos los comandos, uno a la vez.

        No se instaló vlc. Si sabes que puedo hacer ahora te lo agradeceré.

        Seguimos en contacto,
        Saludos

  7. folken2784 permalink
    28/febrero/2011 9:34 am

    hola bueno yo tambien tengo un problema con vlc reproducce de un video los primero 2 seg y luego se cierra allguien me puede ayudar… opensuse 11.3 kde 4.6

Los comentarios están cerrados.

A %d blogueros les gusta esto: