Skip to content

openSUSE 11.0 y el nuevo Zypper

7/junio/2008

El gestor de instalación de paquetes de openSUSE 10.x es lento y en ocasiones no ofrece las mejores soluciones con las dependencias, además al utilizar el clásico formato de metadatos en formato XML (RPM MD (YUM) ), agradable de leer pero que incrementaba significativamente el tamaño de los archivos y además de incrementar el tiempo de transmisión y de procesamiento.

La solución resulta ser uno de los mayores cambios en openSUSE 11.0, un ligero y rápido gestor de paquetes que utilizará los nuevos archivos SOLV utilizados para metadatos. De esta forma se mejora el desempeño, utiliza una fracción de la memoria que utilizan Smart y YUM, es extremadamente rápido en la toma de decisiones más inteligentes con la administración de paquetes (en donde YUM y APT fallan). Lo anterior es de gran interés, ya que el nuevo gestor de paquetes recomendará los mejores paquetes para el hardware en donde este instalado el sistema.

Puedes leer un completo artículo en Sneak Peeks at openSUSE 11.0: Package Management, with Duncan Mac-Vicar, en donde explican con más detalles el “nuevo gestor de paquetes”, hay un vídeo demostrativo y una entrevista a Duncan.

Anuncios
3 comentarios
  1. 8/junio/2008 8:57 pm

    eso de los sistemas de paqueteria esta bien para los usuarios tecnicos ,deberian hacer algo alternativo como los pbi(que enjaulan la liberias),eso seria algo sencillo y practico para instalar aplicaciones.
    lo pueden revisar,la licencia es BSD es decir open source,seria genial que la analizen ,puede servir

    http://www.pbidir.com/bt/pbi/7

  2. 8/junio/2008 10:28 pm

    El problema con lo que propones, es que si liberan una nueva versión de esa librería, sería necesario actualizarla en todos los directorios en donde se encontrara instalada.
    Gracias por tu sugerencia, pero por el momento, el nuevo zypper funciona de lujo!
    Saludos.

  3. 9/junio/2008 1:57 am

    Bueno era una propuesta,pero bueno cada uno tiene su forma de diseño y forma de trabajar.
    Instale la version 10.3 y esta de lujo,estaba pensado en que se podia hacer documentacion hispana de como usar el yast para implementar diversos servicios correo,web,etc,pues es un gran herramienta,claro hay pero la mayoria esta en ingles.
    Si quieres hacerlo yo podria apoyar

Los comentarios están cerrados.

A %d blogueros les gusta esto: